The required version of SharePoint Foundation or SharePoint Server is not installed on this system while developing SharePoint hosted add-in in SharePoint 2016

The required version of SharePoint Foundation or SharePoint Server is not installed on this system while developing SharePoint hosted add-in in SharePoint 2016.

This SharePoint 2013 tutorial explains, how to resolve the issue which comes while SharePoint hosted add-in in SharePoint 2016 using Visual Studio 2015. The error comes as: The required version of SharePoint Foundation or SharePoint Server is not installed on this system. The target version of the SharePoint project is 15.0. The error looks like below:

The required version of SharePoint Foundation or SharePoint Server is not installed on this system
The required version of SharePoint Foundation or SharePoint Server is not installed on this system

Recently I have installed SharePoint 2016, Visual Studio 2015 with developer tools, etc. Then I also Configure On-Premise environment for Apps in SharePoint 2016. But when I tried to create a SharePoint hosted app, in the Specify the SharePoint target version I can see only two options like SharePoint 2013 and SharePoint Online.

The required version of SharePoint Foundation or SharePoint Server is not installed on this system sharepoint 2016
The required version of SharePoint Foundation or SharePoint Server is not installed on this system sharepoint 2016

And then when I deploy the app, it gives me the below error:

The required version of SharePoint Foundation or SharePoint Server is not installed on this system. The target version of the SharePoint project is 15.0.

The required version of SharePoint Foundation or SharePoint Server is not installed on this system

After doing some googling when I install Microsoft Office Developer Tools Preview 2 for Visual Studio 2015 and restart visual studio and I can see all three options like SharePoint 2016, SharePoint 2013 and SharePoint Online.

The required version of SharePoint Foundation or SharePoint Server is not installed on this system
The required version of SharePoint Foundation or SharePoint Server is not installed on this system

Hope this SharePoint tutorial helps to resolve The required version of SharePoint Foundation or SharePoint Server is not installed on this system error which comes while developing apps in SharePoint 2016.

free sharepoint training

SharePoint Online FREE Training

JOIN a FREE SharePoint Video Course (3 Part Video Series)

envelope
envelope

Bijay Kumar

I am Bijay from Odisha, India. Currently working in my own venture TSInfo Technologies in Bangalore, India. I am Microsoft Office Servers and Services (SharePoint) MVP (5 times). I works in SharePoint 2016/2013/2010, SharePoint Online Office 365 etc. Check out My MVP Profile.. I also run popular SharePoint web site SharePointSky.com

>