SharePoint 2013 alerts are not working

sharepoint 2013 alerts are not working

In this article we are addressing the issue “Alerts are not working in SharePoint” from specific site collection of the FARM in SharePoint 2013.

Issue (Alerts not working):

I was not receiving alerts from a specific site collection in my SharePoint on the other hand I am getting alerts from other site collections from the same SharePoint server.

Reason:

Later some research I have realized that alerts on Web Application of the Site Collection. Where we could check that?

Central Administration -> Application Management -> Manage Web Applications -> Select the desired web Application (as shown below)

sharepoint 2013 alerts are not working
sharepoint 2013 alerts are not working

I have realized that alerts were off on that web application.


sharepoint 2013 immediate alerts not working
sharepoint 2013 immediate alerts not working

Enable Alerts from SharePoint Central Admin:

Enable alerts as part of General settings of Web Application and click on OK on the popup window.

Enable Alerts on SharePoint Web Application through PowerShell
Enable Alerts on SharePoint Web Application through PowerShell

Enable Alerts on SharePoint Web Application through PowerShell:

1. Check alerts on the requires web application
$webappUlr = Get-SPWebApplication “<Web Application URL>”
$webappUlr.AlertsEnabled

2. Enable / disable Alerts
$webappUlr = Get-SPWebApplication “<Web Application URL>”
# To enable alerts in this Web application
$webappUlr.AlertsEnabled = $true
$webappUlr.Update()
# To disable alerts in this Web application
$webappUlr.AlertsEnabled = $false
$webappUlr.Update()

Hope this helps !!!!

Similar SharePoint 2013 Tutorials


Leave a Reply