Error while opening content and structure in SharePoint 2013 site collection or sub sites

Error while opening content and structure in SharePoint 2013 site collection or sub sites

In this post, we will discuss how we can resolve the issue which comes when the user clicks on “content and structure” in site settings page in SharePoint 2013. Recently for a subsite few of my users said that they get something went wrong error when they try to open site settings -> content and structure link.

Also, read:
Get a list of pages using a particular page layout using PowerShell in SharePoint 2013

Autocomplete feature in SharePoint 2013 list column using SPServices in SharePoint 2013

The error comes as:
Sorry, something went wrong.
An unexpected error has occurred.
<Correlaton ID:>

Error while opening content and structure in SharePoint 2013 site collection or sub sites
Error while opening content and structure in SharePoint 2013 site collection or sub sites

When we try in other subsites we also found the same issue in all other sub sites as well. The same issue was also there in the top level site as well. Now where people can visit to the content and structure page.

When we check the log with Correlaton ID we found the below very wired message. You can see Get Error Details based on Correlation ID from ULS Logs in SharePoint 2013 using PowerShell.

System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.SharePoint.Publishing.Internal.WebControls.ObjectSerializer.evaluateTestAutomationId(CachedList cachedListToEval) at Microsoft.SharePoint.Publishing.Internal.WebControls.ObjectSerializer.get_AutomationId() at Microsoft.SharePoint.Publishing.Internal.WebControls.EcbEnabledTreeNode.RenderPreText(HtmlTextWriter writer) at System.Web.UI.WebControls.TreeNode.Render(HtmlTextWriter writer, Int32 position, Boolean[] isLast, Boolean enabled) at System.Web.UI.WebControls.TreeNode.RenderChildNodes(HtmlTextWriter writer, Int32 depth, Boolean[] isLast, Boolean enabled) at System.Web.UI.WebControls.TreeNode.Render(HtmlTextWriter writer, Int32 positio…bbf7649d-a272-40a9-44f3-a939c2dc7e82

After lots of R&D we got clue from this article.

We are having the same issue. I checked all the lists and document library in the top level site. And I found when I was trying to open one particular list, it gave me the error Sorry, something went wrong… etc etc etc. When I try to find out the error details from the correlation id, it gave error as:
System.ArgumentException: Feature ‘e004c372-2b1e-439e-a6b0-3c9681343122’ for list template ‘88003’ is not installed in this farm. The operation could not be completed.

Basically, that was the corrupted issue, which was causing the issue.

Then I remove the list from the site contents page.

Error while opening content and structure in SharePoint 2016 site collection or sub sites
Error while opening content and structure in SharePoint 2016 site collection or sub sites

Else we can use PowerShell to delete that particular list. After that when I try to open content and structure, it worked fine.

Hope this will be helpful to you.


You May Also like the Following SharePoint Online Tutorials:

About Bijay Kumar

I am Bijay from Odisha, India. Currently working in my own venture TSInfo Technologies in Bangalore, India. I am Microsoft Office Servers and Services (SharePoint) MVP (5 times). I works in SharePoint 2016/2013/2010, SharePoint Online Office 365 etc. Check out My MVP Profile.. I also run popular SharePoint web site SharePointSky.com

View all posts by Bijay Kumar →